import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[^\\n][\\n]?)+) #flashcard ?\\n*\\(tab\\)((?:(?:.{1,3}$|.{4}(?<!<!--).*)\\n?)+)";
final String string = "- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard\n\n"
+ "(tab)- Empresário rural e ao\n"
+ "(tab)- Pequeno empresário\n\n"
+ "group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao\n\n"
+ "group 2:\n"
+ "(tab)- Empresário rural e ao\n"
+ "(tab)- Pequeno empresário";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}