# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[^\n][\n]?)+) #flashcard ?\n*\(tab\)((?:(?:.{1,3}$|.{4}(?<!<!--).*)\n?)+)"
test_str = ("- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard\n\n"
"(tab)- Empresário rural e ao\n"
"(tab)- Pequeno empresário\n\n"
"group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao\n\n"
"group 2:\n"
"(tab)- Empresário rural e ao\n"
"(tab)- Pequeno empresário")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.