$re = '~"(\S+)"\s*=\s*"([^"]*)";~';
$str = '/* Remove */
"REMOVE" = "Lös \\
ch \\
en \\
";
/* Remove */
"REMOVE" = "Löschen \\
";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);