import re
regex = re.compile(r"\"(\S+)\"\s*=\s*\"([^\"]*)\";")
test_str = ("/* Remove */\n"
"\"REMOVE\" = \"Lös \\\n"
"ch \\\n"
"en \\\n"
"\";\n\n\n"
"/* Remove */\n"
"\"REMOVE\" = \"Löschen \\\n"
"\";")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")