import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\\\]+$)";
final String string = "C:\\Users\\nahar.abhishek\\.m2\\repository\\org\\apache\\kafka\\connect-api\\0.10.1.0-SNAPSHOT\\connect-api-0.10.1.0-SNAPSHOT.jar; error in opening zip file\n"
+ "C:\\Users\\nahar.abhishek\\.m2\\repository\\io\\confluent\\kafka-connect-avro-converter\\3.1.0-SNAPSHOT\\kafka-connect-avro-converter-3.1.0-SNAPSHOT.jar; error in opening zip file";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}