import Foundation
let pattern = #"([^\\]+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C:\Users\nahar.abhishek\.m2\repository\org\apache\kafka\connect-api\0.10.1.0-SNAPSHOT\connect-api-0.10.1.0-SNAPSHOT.jar; error in opening zip file
C:\Users\nahar.abhishek\.m2\repository\io\confluent\kafka-connect-avro-converter\3.1.0-SNAPSHOT\kafka-connect-avro-converter-3.1.0-SNAPSHOT.jar; error in opening zip file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}