const regex = /([^\\]+$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\\]+$)', '')
const str = `C:\\Users\\nahar.abhishek\\.m2\\repository\\org\\apache\\kafka\\connect-api\\0.10.1.0-SNAPSHOT\\connect-api-0.10.1.0-SNAPSHOT.jar; error in opening zip file
C:\\Users\\nahar.abhishek\\.m2\\repository\\io\\confluent\\kafka-connect-avro-converter\\3.1.0-SNAPSHOT\\kafka-connect-avro-converter-3.1.0-SNAPSHOT.jar; error in opening zip file`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}