$re = '/([^\\\\]+$)/';
$str = 'C:\\Users\\nahar.abhishek\\.m2\\repository\\org\\apache\\kafka\\connect-api\\0.10.1.0-SNAPSHOT\\connect-api-0.10.1.0-SNAPSHOT.jar; error in opening zip file
C:\\Users\\nahar.abhishek\\.m2\\repository\\io\\confluent\\kafka-connect-avro-converter\\3.1.0-SNAPSHOT\\kafka-connect-avro-converter-3.1.0-SNAPSHOT.jar; error in opening zip file';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);