use strict;
my $str = 'C:\\Users\\nahar.abhishek\\.m2\\repository\\org\\apache\\kafka\\connect-api\\0.10.1.0-SNAPSHOT\\connect-api-0.10.1.0-SNAPSHOT.jar; error in opening zip file
C:\\Users\\nahar.abhishek\\.m2\\repository\\io\\confluent\\kafka-connect-avro-converter\\3.1.0-SNAPSHOT\\kafka-connect-avro-converter-3.1.0-SNAPSHOT.jar; error in opening zip file';
my $regex = qr/([^\\]+$)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}