#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a href="(?![^>]*?test=abc">[^"]*?>)[^"]*">([^<]+)<\/a>"
Local $sString = "<a href="testsite.com?test=abc">Test Content 4</a>" & @CRLF & _
"<a href="testsite.com?test=123">Test Content yes</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")