$re = '/<a href="(?![^>]*?test=abc">[^"]*?>)[^"]*">([^<]+)<\/a>/';
$str = '<a href="testsite.com?test=abc">Test Content 4</a>
<a href="testsite.com?test=123">Test Content yes</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);