const regex = /<a href="(?![^>]*?test=abc">[^"]*?>)[^"]*">([^<]+)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="(?![^>]*?test=abc">[^"]*?>)[^"]*">([^<]+)<\\\/a>', 'g')
const str = `<a href="testsite.com?test=abc">Test Content 4</a>
<a href="testsite.com?test=123">Test Content yes</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}