re = /<a href="(?![^>]*?test=abc">[^"]*?>)[^"]*">([^<]+)<\/a>/
str = '<a href="testsite.com?test=abc">Test Content 4</a>
<a href="testsite.com?test=123">Test Content yes</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end