using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""(?![^>]*?test=abc"">[^""]*?>)[^""]*"">([^<]+)<\/a>";
string input = @"<a href=""testsite.com?test=abc"">Test Content 4</a>
<a href=""testsite.com?test=123"">Test Content yes</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}