import re
regex = re.compile(r"<b>(.*)<\/b>", flags=re.DOTALL)
test_str = ("somestring<b>Test:<br>\n"
"EUR/USD - "Expect for <i>PRICE BREAKOUT</i>"<br>\n"
"Sell : 1.06809<br>\n"
"Target : 1.06309<br>\n"
"Stop Loss : 1.07309</b><br>rest of html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")