#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<check_name1>[A-Za-z]\w+)\-(?<check_name2>[A-Za-z]\w+)\-(?<state>\w+)\s+(?<location>[^\[]+) \[(?<browser>[^\]]+)\]\s+(?<avg_response_time>\d+)"
Local $sString = " name1-name2-Uptime N. California [RealBrowser] 8419 100 0 23" & @CRLF & _
" name1-name2-Uptime N. Virginia [RealBrowser] 10062 100 0 25" & @CRLF & _
" name1-name2-Uptime Chicago, IL [RealBrowser] 6882 95.83300018 1 24" & @CRLF & _
" name1-name2-Uptime Dallas, TX [RealBrowser] 9558 100 0 23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")