use strict;
my $str = ' name1-name2-Uptime N. California [RealBrowser] 8419 100 0 23
name1-name2-Uptime N. Virginia [RealBrowser] 10062 100 0 25
name1-name2-Uptime Chicago, IL [RealBrowser] 6882 95.83300018 1 24
name1-name2-Uptime Dallas, TX [RealBrowser] 9558 100 0 23';
my $regex = qr/(?<check_name1>[A-Za-z]\w+)\-(?<check_name2>[A-Za-z]\w+)\-(?<state>\w+)\s+(?<location>[^\[]+) \[(?<browser>[^\]]+)\]\s+(?<avg_response_time>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}