re = /(?<check_name1>[A-Za-z]\w+)\-(?<check_name2>[A-Za-z]\w+)\-(?<state>\w+)\s+(?<location>[^\[]+) \[(?<browser>[^\]]+)\]\s+(?<avg_response_time>\d+)/m
str = ' name1-name2-Uptime N. California [RealBrowser] 8419 100 0 23
name1-name2-Uptime N. Virginia [RealBrowser] 10062 100 0 25
name1-name2-Uptime Chicago, IL [RealBrowser] 6882 95.83300018 1 24
name1-name2-Uptime Dallas, TX [RealBrowser] 9558 100 0 23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end