import re
regex = re.compile(r"(?<check_name1>[A-Za-z]\w+)\-(?<check_name2>[A-Za-z]\w+)\-(?<state>\w+)\s+(?<location>[^\[]+) \[(?<browser>[^\]]+)\]\s+(?<avg_response_time>\d+)", flags=re.MULTILINE)
test_str = (" name1-name2-Uptime N. California [RealBrowser] 8419 100 0 23\n"
" name1-name2-Uptime N. Virginia [RealBrowser] 10062 100 0 25\n"
" name1-name2-Uptime Chicago, IL [RealBrowser] 6882 95.83300018 1 24\n"
" name1-name2-Uptime Dallas, TX [RealBrowser] 9558 100 0 23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")