import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<check_name1>[A-Za-z]\\w+)\\-(?<check_name2>[A-Za-z]\\w+)\\-(?<state>\\w+)\\s+(?<location>[^\\[]+) \\[(?<browser>[^\\]]+)\\]\\s+(?<avg_response_time>\\d+)";
final String string = " name1-name2-Uptime N. California [RealBrowser] 8419 100 0 23\n"
+ " name1-name2-Uptime N. Virginia [RealBrowser] 10062 100 0 25\n"
+ " name1-name2-Uptime Chicago, IL [RealBrowser] 6882 95.83300018 1 24\n"
+ " name1-name2-Uptime Dallas, TX [RealBrowser] 9558 100 0 23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}