# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?![^.]+$)|[^-0-9.]|-(?!.*-)//gm;t' <<< "-1.06581.4e-14"