import re
regex = re.compile(r"\.(?![^.]+$)|[^-0-9.]|-(?!.*-)", flags=re.MULTILINE)
test_str = "-1.06581.4e-14"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)