re = /\.(?![^.]+$)|[^-0-9.]|-(?!.*-)/m
str = '-1.06581.4e-14'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result