const regex = /\.(?![^.]+$)|[^-0-9.]|-(?!.*-)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?![^.]+$)|[^-0-9.]|-(?!.*-)', 'gm')
const str = `-1.06581.4e-14`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);