$re = '/\.(?![^.]+$)|[^-0-9.]|-(?!.*-)/m';
$str = '-1.06581.4e-14';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;