# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\bstart:|\G(?!^))\.?\K\d+/0/gm;t' <<< "scores:start:4.2.1.3.4.3:final:55.34.13.63.44.34"