$re = '/(?:\bstart:|\G(?!^))\.?\K\d+/m';
$str = 'scores:start:4.2.1.3.4.3:final:55.34.13.63.44.34';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;