import re
regex = re.compile(r"(?:\bstart:|\G(?!^))\.?\K\d+", flags=re.MULTILINE)
test_str = "scores:start:4.2.1.3.4.3:final:55.34.13.63.44.34"
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)