import Foundation
let pattern = #"(?:\bstart:|\G(?!^))\.?\K\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"scores:start:4.2.1.3.4.3:final:55.34.13.63.44.34"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)