use strict;
my $str = 'scores:start:4.2.1.3.4.3:final:55.34.13.63.44.34';
my $regex = qr/(?:\bstart:|\G(?!^))\.?\K\d+/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";