#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(?:\w+/?){0,2}$"
Local $sString = "/" & @CRLF & _
"/abc" & @CRLF & _
"/def/" & @CRLF & _
"/ghi/jkl" & @CRLF & _
"/mno/pqr/" & @CRLF & _
"/stu/vwx/yz" & @CRLF & _
"/abc/def/ghi/jkl" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/abc" & @CRLF & _
"/def/" & @CRLF & _
"/ghi/jkl" & @CRLF & _
"/mno/pqr/" & @CRLF & _
"/stu/vwx/" & @CRLF & _
"/abc/def/" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"/abc" & @CRLF & _
"/def/" & @CRLF & _
"/ghi/jkl" & @CRLF & _
"/mno/pqr/" & @CRLF & _
"/stu/vwx/yz" & @CRLF & _
"/abc/def/ghi/jkl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")