package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(?:\w+/?){0,2}$`)
var str = `/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/
/abc/def/
/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}