re = /^\/(?:\w+\/?){0,2}$/m
str = '/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/
/abc/def/
/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end