import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/(?:\\w+/?){0,2}$";
final String string = "/\n"
+ "/abc\n"
+ "/def/\n"
+ "/ghi/jkl\n"
+ "/mno/pqr/\n"
+ "/stu/vwx/yz\n"
+ "/abc/def/ghi/jkl\n\n\n"
+ "/abc\n"
+ "/def/\n"
+ "/ghi/jkl\n"
+ "/mno/pqr/\n"
+ "/stu/vwx/\n"
+ "/abc/def/\n\n"
+ "/\n"
+ "/abc\n"
+ "/def/\n"
+ "/ghi/jkl\n"
+ "/mno/pqr/\n"
+ "/stu/vwx/yz\n"
+ "/abc/def/ghi/jkl";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}