$re = '%^/(?:\w+/?){0,2}$%m';
$str = '/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/
/abc/def/
/
/abc
/def/
/ghi/jkl
/mno/pqr/
/stu/vwx/yz
/abc/def/ghi/jkl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);