#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^0-9]*[0-9]{1,2}[^0-9]*$"
Local $sString = "foo1bar" & @CRLF & _
"foobar1" & @CRLF & _
"f12obar" & @CRLF & _
"12foobar" & @CRLF & _
"f1o2obar" & @CRLF & _
"f1o23obar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")