$re = '/^[^0-9]*[0-9]{1,2}[^0-9]*$/m';
$str = 'foo1bar
foobar1
f12obar
12foobar
f1o2obar
f1o23obar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);