// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^0-9]*[0-9]{1,2}[^0-9]*$").unwrap();
let string = "foo1bar
foobar1
f12obar
12foobar
f1o2obar
f1o23obar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}