import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^0-9]*[0-9]{1,2}[^0-9]*$";
final String string = "foo1bar\n"
+ "foobar1\n"
+ "f12obar\n"
+ "12foobar\n"
+ "f1o2obar\n"
+ "f1o23obar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}