re = /^[^0-9]*[0-9]{1,2}[^0-9]*$/m
str = 'foo1bar
foobar1
f12obar
12foobar
f1o2obar
f1o23obar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end