const regex = /^(\p{L}+)\s*(.*?)\s+(\d{5})\s+([-+\d\s()\/]{7,})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{L}+)\\s*(.*?)\\s+(\\d{5})\\s+([-+\\d\\s()\\\/]{7,})$', '')
const str = `May Business Park E2 No. 12, Jakarta, Indonesia 11620 +6281932539817`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}