// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\p{L}+)\s*(.*?)\s+(\d{5})\s+([-+\d\s()\/]{7,})$").unwrap();
let string = "May Business Park E2 No. 12, Jakarta, Indonesia 11620 +6281932539817";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}