import re
regex = re.compile(r"^(\p{L}+)\s*(.*?)\s+(\d{5})\s+([-+\d\s()\/]{7,})$")
test_str = "May Business Park E2 No. 12, Jakarta, Indonesia 11620 +6281932539817"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")