$re = '/^(\p{L}+)\s*(.*?)\s+(\d{5})\s+([-+\d\s()\/]{7,})$/';
$str = 'May Business Park E2 No. 12, Jakarta, Indonesia 11620 +6281932539817';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);