re = /^(\p{L}+)\s*(.*?)\s+(\d{5})\s+([-+\d\s()\/]{7,})$/
str = 'May Business Park E2 No. 12, Jakarta, Indonesia 11620 +6281932539817'
# Print the match result
str.match(re) do |match|
puts match.to_s
end