# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^@([A-z1-9_\-\.]*?)\ *:\ *\"?(.*?)\"?;$/\1 -> \2/mg;t' <<< "@Title : \"BinarSkugga\";
@Username : \"Test\";"