re = /^@([A-z1-9_\-\.]*?)\ *:\ *\"?(.*?)\"?;$/m
str = '@Title : "BinarSkugga";
@Username : "Test";'
subst = '\\1 -> \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result