using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(_{2}\([\'\""]{1})([a-zA-Z1-9\s%\_\'\.\,(\""\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\""\))*]+)";
string input = @"__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()));
__(""Invalid File"".$something."" Extension"");
__(""Employers9"");
_sometime
__('Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!')
__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()))
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}