const regex = /^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(_{2}\\([\\\'\\"]{1})([a-zA-Z1-9\\s%\\_\\\'\\.\\,(\\"\\))*\\(\\=\\>\\$\\-\\!]*[(\\){1,3})*(\\\'\\)*)(\\){1,3})*(\\"\\))*]+)', '')
const str = `__('Register and apply for %job_title%', array('%job_title%' => \$job->getTitle()));
__("Invalid File".\$something." Extension");
__("Employers9");
_sometime
__('Please read the Privacy Policy and tick \$the %ceva%box to say you have done so.!')
__('Register and apply for %job_title%', array('%job_title%' => \$job->getTitle()))
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}