import Foundation
let pattern = #"^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()));
__("Invalid File".$something." Extension");
__("Employers9");
_sometime
__('Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!')
__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}